Deployment Architecture

Getting SAML error after upgrade to Splunk v. 7.0.0.1 "SAML config is invalid, Reconfigure it"

Builder

We upgraded our Splunk search head from version 6.5.3 to version 7.0.0.1 and cannot get to GUI interface: getting "Page not found!" error message (URL :
https://servername/en-US/?samlstatus=Invalid%20configuration.%20'idpSsoUrl'%20is%20missing.%20Invali....)

splunkd.log has the following error: 0500 ERROR UserManagerPro - SAML config is invalid, Reconfigure it. and 0500 ERROR UserManagerPro - user="system" had no roles
We have used SAML successfully in previous version 6.5.3 , idpSsoUrl' is setup in authentication.conf file as well.

Will appreciate all advices on what can be the next step

Builder

Which IdP are you using?

Try to generate your spmetadata.xml again on the upgraded search head and compare with the original spmetadata file you gave to your IdP. Is it the same?

0 Karma

Builder

@suarezry, we are using Ping Identity. What do you mean under "generate your spmetadata.xml" again?

0 Karma

Builder

https://docs.splunk.com/Documentation/Splunk/7.0.0/Security/ConfigureSAMLSSO#Configure_your_identity...

Note that you can export Splunk software metadata using the /saml/spmetadata endpoint on Splunk Web. You can also access the SAML-sp-metadata endpoint on splunkd.

@mlevsh
Go to https://yoursplunk.yourdomain.com/saml/spmetadata to generate your metadata. Compare this with the file you provided to Ping Identity. Is it the same?

0 Karma

Builder

@mlevsh
Did you find out what your problem was?

0 Karma

Builder

@suarezry, sorry for a delayed reply. The reason SAML authentication didn't work - we had some deprecated parameters in authentication.conf file.
Found this kind of errors in splunkd.log:
"WARN SSLOptions - authentication.conf/[saml]/sslKeysfilePassword: deprecated; use 'sslPassword' instead
WARN SSLOptions - authentication.conf/[saml]/sslKeysfile: deprecated; use 'clientCert' instead"

After applying this change we were able to get to splunk site

0 Karma