Deployment Architecture

Error while adding search head member

bhupalbobbadi
Path Finder

Anybody have faced this issue?

$ /opt/splunk/bin/splunk add shcluster-member
Deserialization failed. Could not find expected key 'current_member_uri'

Fresh SH installation, all SH, Master running same version 7.2.0.

 

Thanks in advance.

Labels (1)
0 Karma

bhupalbobbadi
Path Finder

Just found the fix.
Instead of adding the new SH to cluster from new Sh, add the new SH from captain SH.

splunk add shcluster-member -new_member_uri <URI>:<management_port>

 that solved the problem.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...