Deployment Architecture
Highlighted

Error deploying an app from Windows deploy server to *nix forwarder

Explorer

Upgrading the Windows 2008 Indexer/Deploy Server from 4.1.x to 4.2.2 the deploy server can't deploy *nix apps due to the error:

07-11-2011 14:21:00.484 -0100 WARN DeployedServerClass - There was a problem installing app: TerraSunAuthlog for server class: cTerraSunAuthlog
07-11-2011 14:22:01.039 -0100 WARN DeployedApplication - Installing app: Terra
SunAuthlog to location: /opt/splunk\etc\apps/TerraSunAuthlog
07-11-2011 14:22:01.084 -0100 ERROR DeployedApplication - Failed to install app : /opt/splunk\etc\apps/Terra
SunAuthlog. Application does not exist: TerraSun_Authlog

I can see some mixing with slash and (windows) back slash on the path!

Any suggestion or workaround? Thank you.

Tags (2)
0 Karma
Highlighted

Re: Error deploying an app from Windows deploy server to *nix forwarder

New Member

On the linux machine where the app is being deployed you need this line in your deploymentclient.conf file: repositoryLocation = $SPLUNK_HOME/etc/apps

This will fix the wrong slashes, at least it did for me.

0 Karma
Highlighted

Re: Error deploying an app from Windows deploy server to *nix forwarder

Explorer

In my instance, "$SPLUNK_HOME/etc/apps" wasn't known, so for the serverclass specific to Linux, I added the full path.

Probably nothing to do with Splunk, rather my "PATH" settings on Linux, but it may help others.

0 Karma
Highlighted

Re: Error deploying an app from Windows deploy server to *nix forwarder

Explorer

I already solved the problem adding the below lines on the deploymentclient.conf file of the *nix forwarders:

[deployment-client]

repositoryLocation = $SPLUNK_HOME/etc/apps

serverRepositoryLocationPolicy = rejectAlways

Thanks anyway, bye.

0 Karma