Deployment Architecture

Deployment Client not finding deploymentclient.conf??

Path Finder

Hi.

I'm trying to set up a Universal Forwarder as a deployment client on Windows. I install splunkforwarder...msi via the CLI, and I do NOT use the "DEPLOYMENT_SERVER" flag. Instead, I want the deployment client to get that information from deploymentclient.conf.

So... I place the deploymentclient.conf file at the following location:

C:\Program Files\SplunkUniversalForwarder\etc\apps\mf_Laptop\local

("mf_Laptop" is the name of the app to which the Deployment Server will push inputs.conf, etc.)

My deploymentclient.conf is very simple:

[target-broker:deploymentServer]

targetUri = myhostname:9996

But... it's NOT working. The Deployment Client is not phoning home, so it never gets inputs.conf and outputs.conf, etc.

In the splunkd.log, on the Deployment Client, I see the following entry:

WARN DeploymentClient - Property targetUri not found. DeploymentClient is disabled.

So, I'm guessing that the Deployment Client is not picking up deploymentclient.conf from the app directory listed above.

Incidentally, another Windows Deployment Client is working fine, using the same deploymentclient.conf file. The big difference, however, is that on the working Windows Deployment Client, deploymentclient.conf is located in:

C:\Program Files\SplunkUniversalForwarder\etc\system\local

So... Why isn't my new Deployment Client picking up the Deployment Server's info from deploymentclient.conf in the app directory, and how can I make him do so???

(Note: I have done a "splunk restart" on the Deployment Client since everything has been set up, but that didn't help.

Thx y'all..

mfeeny1

Tags (1)
0 Karma

Path Finder

Spunk support has submitted this as a bug. I will update this thread as that process moves along.

0 Karma

Path Finder

I have an Update. I moved my deploymentclient.conf file into "system\etc\local", and did a "splunk restart", and this did NOT change anything. Same Warning message in splunkd.log. So my theory that the location of deploymentclient.conf was the problem has been disproved.

I'll keep plugging away, and keep my eyes on this forum for any other ideas.

thx,
mfeeny1

0 Karma

Super Champion

Do you have the deployment client enabled in deploymentclient.conf?

[deployment-client]
disabled = false

Not 100% sure what the default is for "disabled" in that stanza, but it's worth a try.

0 Karma