Deployment Architecture

Cold bucket move error

jgauthier
Contributor

I recently added a drive to my system, and told my main index to start moving things there when it reached 250G. I seem to be having errors in the log file:

11-19-2013 15:42:23.436 -0500 INFO  BucketMover - idx=main bucket=db_1343977251_1342804621_189 Firing async chiller: from='Z:\splunk\defaultdb\db' to='E:\splunk\defaultdb\colddb'
11-19-2013 15:42:23.436 -0500 INFO  DbMaxSizeManager - Bucket moved successfully (size: cur=260701782997 (248624MB,242GB), max=262144000000 (250000MB,244GB))
11-19-2013 15:42:23.436 -0500 ERROR BucketMover - aborting move because could not remove existing='E:\splunk\defaultdb\colddb\inflight-db_1343977251_1342804621_189' (reason='The operation completed successfully.')

I do not actually believe any data is being moved. any ideas?

Tags (1)
0 Karma

jgauthier
Contributor

Resolved by granting the splunk service account appropriate permissions to the new drive/folder.

0 Karma

jgauthier
Contributor

There it is! This was a windows permission issue. The file structure was created successfully, by the service, but the service could not execute this until the new drive had appropriate permissions for the splunk service account.

0 Karma

MuS
SplunkTrust
SplunkTrust

Can you verify if the buckets were moved or not? Could you turn on Debug for the BucketMover channel and if you get more details for this? Permission problem?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...