Dashboards & Visualizations
Highlighted

how to disable drilldown for the last row of the table ?

Builder

In my table the last row is the "Average" of all the columns which is calculated based on the query. I want to disable the drilldown click for it. how it can be done ? Attaching image for your reference.

Below is the snippet of query I am using for the table :

| transpose header_field=Category 10 | addtotals | eval Average=round(Total/8,0)| fields - Total | table column "Availability Management" "Identity Access & AD" "Information Security Management" "Monitoring & Analysis" "Server & Storage" "Service Asset & Configuration Mangement" "Service Management" Others Average | transpose header_field=column 25 | rename column as Category

alt text

Labels (2)
0 Karma
Highlighted

Re: how to disable drilldown for the last row of the table ?

SplunkTrust
SplunkTrust

@pgadhari

You can ignore the click using the below code. Can you please try this?

<drilldown>
    <condition match="match('click.value',&quot;Average&quot;)">
        <!--  Intentionally Kept Blank-->
    </condition>
    <!-- Put here other values's condition-->
    <!-- OR put single condition for all values -->
    <condition>
    </condition>
</drilldown>

Thanks

View solution in original post

0 Karma
Highlighted

Re: how to disable drilldown for the last row of the table ?

Builder

@kamlesh_vaghela - when I try to add that conditional-drilldown, it gives following warning :

invalid child="set" is not allowed in node=conditional-drilldown"

below is my XML code, I am already using for that row (table)

 <drilldown>
          <set token="tok_sas_cat">$click.value$</set>
          <unset token="tok_fm_cat"></unset>
          <unset token="tok_al_cat"></unset>
          <condition match="match('click.value',&quot;Average&quot;)">

          </condition>
          <!-- Put here other values's condition-->
          <!-- OR put single condition for all values -->
          <condition>
          </condition>
 </drilldown>

Also, do I need to put any values where you have written "Put here other value's condition" ??

0 Karma
Highlighted

Re: how to disable drilldown for the last row of the table ?

Builder

some how the set token word did not come. I am already using "set" token in my drilldown option, due to which it is not allowing to put the conditional-drilldown ? please advise ?

0 Karma
Highlighted

Re: how to disable drilldown for the last row of the table ?

SplunkTrust
SplunkTrust

@pgadhari

Can you please try this?

<drilldown>           
  <condition match="match('click.value',&quot;Average&quot;)">

  </condition>
  <condition>
    <set token="tok_sas_cat">$click.value$</set>
    <unset token="tok_fm_cat"></unset>
    <unset token="tok_al_cat"></unset>
  </condition>
</drilldown>
Highlighted

Re: how to disable drilldown for the last row of the table ?

Builder

yes it worked. That was easy. 🙂 Thank you very much.

0 Karma