Dashboards & Visualizations

help to open a drilldown from a pie chart slice

jip31
Motivator

Hi

 

From the code below, I display a pie chart in order to display the top 10 of EventCode

index="toto" sourcetype=tutu EventCode=* (Level=1 OR Level=2 OR Level=3) 
| fields _time host EventCode  
| eval time = strftime(_time, "%m/%d/%Y %H:%M") 
| stats count(host) as "Number of EventCode" by EventCode 
| sort -"Number of EventCode" 
| head 10

 Now, I need to open a drilldown when I click on a slice of the pie chart

I modified my xml like this but it doesnt works

  <init>
    <set token="EventCode">*</set>
  </init>

   <drilldown>
     <set token="EventCode">$click.value$</set>
     <link target="_blank">/app/titi/eee</link>
    </drilldown>

 Could you help me please?

Labels (1)
Tags (1)
0 Karma
1 Solution

bowesmana
SplunkTrust
SplunkTrust

What does not work?

The <drilldown> section needs to be part of the dashboard <chart> element.

Does the drilldown open up a new page and not find the target or does the drilldown not happen.

You will also need the following as part of the <chart> definition

<option name="charting.drilldown">all</option>

Hope this helps 

View solution in original post

0 Karma

bowesmana
SplunkTrust
SplunkTrust

What does not work?

The <drilldown> section needs to be part of the dashboard <chart> element.

Does the drilldown open up a new page and not find the target or does the drilldown not happen.

You will also need the following as part of the <chart> definition

<option name="charting.drilldown">all</option>

Hope this helps 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...