Dashboards & Visualizations

Why are my forms that link to an external URL not working?

rbardonetorian
Path Finder

All,

After following the help page located here: http://docs.splunk.com/Documentation/Splunk/6.5.3/Viz/Dynamicdrilldownindashboardsandforms#Form_link...

I am still unable to be directed to external site (of splunk app).

My Code used:

    <option name="count">8</option>
    <option name="height">400</option>
    <option name="drilldown">row</option>
    <option name="refresh.display">none</option>
    <option name="rowNumbers">0</option>
    <option name="showPager">1</option>
    <option name="fontColor">#ccc</option>
    <drilldown>
      <link target="_blank">http://10.0.1.40/report/$row.ID$/summary/</link>
    </drilldown>

I have also tried :

<![CDATA[[ http://10.0.1.40/report/$row.ID$/summary/ ]]>

No joy...

Any help is appreciated!

V. 6.5.3

0 Karma
1 Solution

rbardonetorian
Path Finder

I have also tried:

       <drilldown>
          <link target="blank"><![CDATA[http://10.0.1.40/report/$row.ID$/summary/]]></link>
        </drilldown>

With no joy..

The result is a new page opening and chopping off the front piece of the URL that should have been passed.
ie: https://report/14/summary/

As you see the IP address is missing and it defaulted back to the HTTPS protocol. Is this a security feature of some sort keeping all tranmissions HTTPS if the Splunk server is HTTPS? (yes my Splunk server has HTTPS enabled)

Thanks!

View solution in original post

0 Karma

rbardonetorian
Path Finder

I have also tried:

       <drilldown>
          <link target="blank"><![CDATA[http://10.0.1.40/report/$row.ID$/summary/]]></link>
        </drilldown>

With no joy..

The result is a new page opening and chopping off the front piece of the URL that should have been passed.
ie: https://report/14/summary/

As you see the IP address is missing and it defaulted back to the HTTPS protocol. Is this a security feature of some sort keeping all tranmissions HTTPS if the Splunk server is HTTPS? (yes my Splunk server has HTTPS enabled)

Thanks!

0 Karma

rbardonetorian
Path Finder

This is / was EXACTLY the problem. (Security Feature) I tried HTTPS and it passed just fine.

Thanks all. Looks like I need to get https enabled on my reports server.

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi rbardonetorian,
try something like this:

<drilldown>
   <![CDATA[http://10.0.1.40/report/$row.ID$/summary/]]>
</drilldown>

Bye.
Giuseppe

0 Karma
Get Updates on the Splunk Community!

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...