Dashboards & Visualizations

Why FlashTimeline disappears after zooming to selection or double click in advanced XML dashboard in Splunk 6.1?

New Member

I have an advanced xml dashboard in Splunk 6.1, when I zoom into the flashtimeline by double clicking or using the zoom to selection link the search is re-run and the flashtimeline disappears. If I use the datetimepicker to explicitly go to the same period of time the flashtimeline works fine.

How can I fix it so the flashtimeline stays present when I zoom in?

This dashboard may seem like a trivial example for advanced xml but it is simplified to demonstrate the issue.

<view autoCancelInterval="100" onunloadCancelJobs="False">
  <label>experimental - Google Maps - oron events</label>
  <description/>
  <module name="AccountBar" layoutPanel="appHeader"/>
  <module name="AppBar" layoutPanel="navigationHeader"/>
  <module name="Message" layoutPanel="messaging">
    <param name="filter">*</param>
    <param name="clearOnJobDispatch">False</param>
    <param name="maxSize">1</param>
  </module>
 <module name="HiddenSearch"  autoRun="True" layoutPanel="splSearchControls-inline">
    <param name="maxCount">100000</param>
    <param name="search">
      <![CDATA[
index="meters" *]]>
    </param>
    <module name="TimeRangePicker" >
      <param name="selected">All time</param>
      <param name="searchWhenChanged">True</param>
      <module name="FlashTimeline" layoutPanel="graphArea">
        <param name="height">140px</param>
        <param name="width">100%</param>     
        <module name="Paginator">
          <param name="entityName">events</param>
          <param name="count">100</param>
          <module name="SoftWrap">
            <param name="enable">true</param>
            <module name="EventsViewer">
              <param name="enableBehavior">False</param>
              <param name="enableEventActions">False</param>
              <param name="enableFieldActions">False</param>
              <param name="enableTermSelection">False</param>
            </module>
          </module>
        </module>
      </module>
   </module>
  </module>
</view>
0 Karma
1 Solution

Splunk Employee
Splunk Employee

A case with Splunk Support has been opened for this topic, the resolution required a code fix which will be included in 6.1.6 and 6.2.2

View solution in original post

Splunk Employee
Splunk Employee

A case with Splunk Support has been opened for this topic, the resolution required a code fix which will be included in 6.1.6 and 6.2.2

View solution in original post