Dashboards & Visualizations

StaticSelect drilldown issue

ypfbkg
Explorer

I set a staticselect for a chart, it works.
but when I click the chart bar to drilldown to other hiddensearch, the select values can't work.
What am I missing?
I reference below answer, but still don't work.

http://splunk-base.splunk.com/answers/3472/drilldown-with-stringreplace-intention

anyone can help this issue ? Thanks.

my xml:

<module name="TimeRangePicker" layoutPanel="mainSearchControls" autoRun="false">
  <!--<param name="selected">Last 60 minutes</param>-->
  <param name="searchWhenChanged">false</param>
  <module name="StaticSelect">
    <param name="settingToCreate">instance_setting</param>
    <param name="label">Instance:</param>
    <param name="staticFieldsToDisplay">
      <list>
        <param name="label">s1etrex:8080</param>
        <param name="value">s1etrex*:8080</param>
      </list>
      <list>
        <param name="label">s1etrex:9090</param>
        <param name="value">s1etrex*:9090</param>
      </list>
    </param>
    <module name="ConvertToIntention">
      <param name="settingToConvert">instance_setting</param>
      <param name="intention">
        <param name="name">stringreplace</param>
        <param name="arg">
          <param name="instance_value">
            <param name="value">$target$</param>
          </param>
        </param>
      </param>


        <module name="SubmitButton">
          <param name="allowSoftSubmit">false</param>
          <param name="label">Search</param>

          <module name="GenericHeader" layoutPanel="resultsAreaLeft">
            <param name="label">Instance usage by Day</param>
          </module>
          <module name="HiddenSearch" layoutPanel="resultsAreaLeft">
            <param name="search"> sourcetype="etrexacclog" instance = "$instance_value$" | eval instance = case(instance =="s1etrex.ad.com:8080" , "s1etrex:8080", instance =="s1etrex.ad.com:9090" , "s1etrex:9090", instance =="s1etrex:8080" , "s1etrex:8080", instance =="s1etrex:9090" , "s1etrex:9090") | timechart span="1d" count(instance)</param>
            <module name="HiddenChartFormatter">
              <param name="chart">column</param>
              <param name="primaryAxisTitle.text">_time</param>
              <param name="secondaryAxisTitle.text">usage</param>
              <param name="legend.placement">usage</param>
              <module name="JobProgressIndicator"/>
              <module name="FlashChart">
                <param name="width">100%</param>
                <param name="height">400px</param>
                <module name="ConvertToIntention">
                  <param name="settingToConvert">instance_setting</param>
                  <param name="intention">
                    <param name="name">stringreplace</param>
                    <param name="arg">
                      <param name="instance_value2">
                        <param name="value">$target$</param>
                      </param>
                    </param>
                  </param>
                <module name="HiddenSearch">

                  <param name="search">sourcetype="etrexacclog" instance="$instance_value2$" app!="*interview*" app!="*Mozilla" app!="*preview*" |chart count(app) as usage by app</param>

                  <module name="JobProgressIndicator"></module>

                  <!-- We throw in a header so we can tell the user what they clicked on. -->
                  <module name="SimpleResultsHeader">
                    <param name="entityName">results</param>
                    <param name="headerFormat">Detail apps on $time$</param>
                  </module>
                  <module name="HiddenChartFormatter">
                    <param name="chart">bar</param>
                    <param name="primaryAxisTitle.text">AppsName</param>
                    <param name="secondaryAxisTitle.text">Usage</param>
                    <param name="legend.placement">Usage</param>
                    <module name="FlashChart">
                      <param name="width">100%</param>
                      <param name="enableResize">False</param>
                      <module name="ViewRedirectorLink">
                        <param name="viewTarget">flashtimeline</param>
                      </module>
                    </module>
                  </module>
                </module>
              </module>
            </module>
          </module>
        </module>
      </module>
    </module>
      </module>
    </module>
Tags (2)
0 Karma
1 Solution

jdunlea_splunk
Splunk Employee
Splunk Employee

Just off the top of my head, try changing the "allowSoftSubmit" to true - this MAY be why the drill down is not being allowed automatically through the submit button.

What exactly is the result that you are seeing when you select the bar on the chart? - Just nothing at all happens??

View solution in original post

0 Karma

jdunlea_splunk
Splunk Employee
Splunk Employee

Just off the top of my head, try changing the "allowSoftSubmit" to true - this MAY be why the drill down is not being allowed automatically through the submit button.

What exactly is the result that you are seeing when you select the bar on the chart? - Just nothing at all happens??

0 Karma

ypfbkg
Explorer

Wow~yes just change to true, it works now.

Thanks.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...