Dashboards & Visualizations

Splunk not displaying all my saved searches in the UI drop down.

the_wolverine
Champion

As of version 5, Splunk will not display all of your saved searches in the UI drop down if you have more than 500 searches saved.

0 Karma
1 Solution

the_wolverine
Champion

Splunk has configured a limit of 500 searches that can be displayed in the search dropdown. To get around this limit you will need to edit the following line in $SPLUNKHOME/lib/python2.7/site-packages/splunk/appserver/mrsparkle/controllers/view.py

searches = en.getEntities('saved/searches', namespace=app, search='is_visible=1 AND disabled=0', count=500, _with_new='1') 

Raise 500 to the desired value.

Note that Splunk has advised that editing view.py is not supported and will be overwritten by any upgrade. Also be advised that there may be performance implications from raising this value.

View solution in original post

the_wolverine
Champion

Splunk has configured a limit of 500 searches that can be displayed in the search dropdown. To get around this limit you will need to edit the following line in $SPLUNKHOME/lib/python2.7/site-packages/splunk/appserver/mrsparkle/controllers/view.py

searches = en.getEntities('saved/searches', namespace=app, search='is_visible=1 AND disabled=0', count=500, _with_new='1') 

Raise 500 to the desired value.

Note that Splunk has advised that editing view.py is not supported and will be overwritten by any upgrade. Also be advised that there may be performance implications from raising this value.

View solution in original post

Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!