Dashboards & Visualizations
Highlighted

Splunk Mobile Access Server: how to enable token-based authentication

Path Finder

In the documentation:
http://docs.splunk.com/Documentation/MobileServer/2.0.1/Install/Createasecureauthenticationstring#En...

... I read that I have to set the parameter authtokensecurity. But in the config_local.json file that parameter is not present.

I tried to add it, but the server does not start giving me "Error parsing your JSON configuration file", probably because I have not put in properly... 😉

Can anyone give me a hint?

0 Karma
Highlighted

Re: Splunk Mobile Access Server: how to enable token-based authentication

Path Finder

Ouch... my stupid mistake: I forgot a comma!

{
  "servers": {
    "m": {
...
      },
      "splunkweb": {
...
      }
    }
  },
  "admin": {
...
  },
  "scheme": "https",
  "port": 443,
  "db": {
...
  },
  "session_key": "T1oFnc",
  "cluster_size": 1,
  "initialized": true,
  "auth_token_security": true
}

In any case, the parameter must be set to true, contrary to what reported in the doc.

View solution in original post

0 Karma
Highlighted

Re: Splunk Mobile Access Server: how to enable token-based authentication

Communicator

I made sure that I added the parameter correctly but mine is still not working. My mobile access server is installed on windows. Do you know what might be the problem? All I added was the last line before the final bracket. No I did not forget to add a comma.

0 Karma
Highlighted

Re: Splunk Mobile Access Server: how to enable token-based authentication

Splunk Employee
Splunk Employee

Sort of glad the mistake occurred so that I had the opportunity to make the correction in the documentation. Thanks, ctux!

Highlighted

Re: Splunk Mobile Access Server: how to enable token-based authentication

Path Finder

nice 🙂 yw!

0 Karma
Highlighted

Re: Splunk Mobile Access Server: how to enable token-based authentication

Path Finder

Some log to share?

0 Karma