Dashboards & Visualizations

Splunk Dashboards are not loading

shahara
New Member

Hi,

I'm using Splunk 6.1.4 and whenever i click on a dashboard it doesn't show anything... I just get the Splunk screen with the name of the dashboard and "Loading" showing on it - no reports are loaded.
I've tried to reboot the server, and it didn't work...

Please assists...

Thanks a lot!
Shahar

Tags (2)
0 Karma

markakirkland
Path Finder

Another consideration could be if Splunk is being redirected through a Gateway, Load Balancer, etc.

Busy Gateways can timeout depending on several variables...

For the purposes of this question, this possibility should be ruled out if it is not a factor.

If it is a factor, switch to Developer mode in your browser (F12), and that should display all communications, good and bad, from client to server.

0 Karma

andrewcg
Path Finder

Clearing my browser (the latest FireFox on Windows 7) cache resolved this issue for me. The "Loading..." message appeared while creating or editing objects, like event types or dashboards. The dashboard editor would never engage, the text was editable, but the color coding never turned on. After the object was saved, I would get the redirect xml code page, but the redirect would not occur. The issue started after a restart of our test Splunk server. The interface for the prod Splunk server was never affected, only the test one. The browser must have been holding onto some piece of info that changed after the restart.

mikaelbje
Motivator

There may be several reasons why this is happening, but the cause on my computer running Chrome was the Adblock Plus extension. I saw this happening when I attempted to open the search view, regardless of in what app. I've seen a lot of different Splunk installs, but have only experienced this at a few of them.

My resolution: Disable Adblock Plus for the site. Also disable Ghostery and Disconnect if disabling Adblock Plus didn't help. Hit refresh.
These extensions block a lot of the JavaScript magic used in modern websites and certain sites and functions simply don't work correctly.

jmheaton
Path Finder

This started happening to us about a week ago.
I am not sure if upgrading to 6.2 is going to fix this little bug.

GOOD NEWS,
I found what fixed it for us. Maybe it will work for yall.
Look in your navigation menu to see if any label is showing up as "none" or "None". After i removed those collections from our Nav it was just fine for us.

0 Karma
Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...