Dashboards & Visualizations

Problems in drill down

allan_newton
Path Finder

This is the basic drill down dashboard.




Drill_Here

<![CDATA[
index=core_data | rex field=Message "(?(Started|Failed|COMPLETED))" | table Region, Event_Time, Status
]]>

0
now
15
false
true


/app/data_Monitoring/simple_test?form.host=$row.Region$ | table Region, Message










Drilled_Here
host=$click.value$ | table Region, Message

0
now
true
false
none



When i click on the first dashboard, I'm redirected to the second dashboard but i get the message "Search Query is not fully resolved"

Please help.

Tags (2)
0 Karma
1 Solution

martin_mueller
SplunkTrust
SplunkTrust

Your first dashboard is passing a token form.host to the second dashboard, but the search in your second dashboard is referencing a token $click.value$. That token isn't set anywhere, so the search can't run.

Your second dashboard should look something like this: http://docs.splunk.com/Documentation/Splunk/6.0.3/Viz/Dynamicdrilldownindashboardsandforms#Destinati...

View solution in original post

martin_mueller
SplunkTrust
SplunkTrust

Your first dashboard is passing a token form.host to the second dashboard, but the search in your second dashboard is referencing a token $click.value$. That token isn't set anywhere, so the search can't run.

Your second dashboard should look something like this: http://docs.splunk.com/Documentation/Splunk/6.0.3/Viz/Dynamicdrilldownindashboardsandforms#Destinati...

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...