Dashboards & Visualizations
Highlighted

Pass a token to a label

Communicator

Hi everyone.

I have this issue, and is really weird. First of all, I have a 6.3 deployment.

If I put the token in a title etiquette all works fine, but when I do the same in a label etiquette like this:

<label>$token$</label>

The first time works fine, but when I reload the dashboard, Splunk adds another pair of $, and I can't see the token's value:

$$token$$

This is weird, but even more when you go to the XML code and it seems to be right:

<label>$token$</label>

but if you click in Edit Panels, and then edit input, I can see in the label text box the next:

$$token$$

If I reformat the token all work fine... until I reload the dashboard (because then all start again).

What's wrong?

I read this question/answer but didn't work for me:
https://answers.splunk.com/answers/126939/pass-token-to-a-label.html

Regards.

0 Karma
Highlighted

Re: Pass a token to a label

Builder

Santi, has probado a poner el caracter $ en modo ASCII ?

quiza necesites CDATA

0 Karma
Highlighted

Re: Pass a token to a label

Communicator

Hola Angel, gracias por la ayuda 😉

He localizado los códigos del caracter $ en esta página: http://dev.w3.org/html5/html-author/charref

Según http://docs.splunk.com/Documentation/Splunk/6.3.0/Viz/OverviewofSimplifiedXML no sería necesario usar la codificación con el símbolo $, pero lo he realizado igualmente tal cual indican en ese documento.

He usado el CDATA con las tres codificaciones posibles, y no funciona ninguna:
&#36; aparece la codificación en lugar del símbolo $
&#x00024; aparece la codificación en lugar del símbolo $
&dollar; aparece la codificación en lugar del símbolo $

Sin el CDATA esto es lo que obtengo:
&#36; ocurre exactamente lo mismo que comento en la pregunta
&#x00024; ocurre exactamente lo mismo que comento en la pregunta, añadiendo que en el XML Splunk traduce la codificación por el símbolo $
&dollar; no lo admite

¿Se te ocurre algo más?

Gracias 🙂

0 Karma
Highlighted

Re: Pass a token to a label

Builder

te pasa en Firefox y en Chrome lo mismo?

0 Karma
Highlighted

Re: Pass a token to a label

Communicator

Con ambos lo mismo, sí.

0 Karma
Highlighted

Re: Pass a token to a label

Builder
otra idea, si lo que estas intentando hacer es poner el titulo a un panel, no es <label> sino <title>
0 Karma
Highlighted

Re: Pass a token to a label

Communicator

Es el título de un input, y solo puede ser con label

:S

0 Karma
Highlighted

Re: Pass a token to a label

Builder

humm.... quiza prueba a contruirte un panel que te diga que tokens estan disponibles en cada momento, puede ser una manera de "debugear"
En la app de ejemplos de dashboards tienes al final un par de opciones para esto. No se si ya lo habras echado un ojo.

Tiens mas info en el link link text

0 Karma
Highlighted

Re: Pass a token to a label

Builder

por ahi la gente comenta que se puede probar a reiniciar splunk con cada cambio que pruebes, pero no le encuentro la logica...

0 Karma
Highlighted

Re: Pass a token to a label

Communicator

Realicé algún reinicio el primer día que me encontré este problema, por probar, pero efectivamente no hay cambio en los resultados.

0 Karma