Dashboards & Visualizations

Multiple dropdown help

kallisrayar1986
Path Finder

I have 2 drop downs, the output of the first one will be the input to the second. After the first drop down selection, if i change the first drop down value the second drop downs displays the last selected value instead of showing an empty or a default value.

Please help.

Simple XML:

1st Dropdown -

  <label>Select a Version:</label>
  <prefix>"</prefix>
  <suffix>"</suffix>
  <default>*</default>
  <choice value="*">Select a version</choice>
  <populatingSearch fieldForValue="version01" fieldForLabel="version01" earliest="0" latest="now">
    <![CDATA[QUERY]]>
  </populatingSearch>
</input>

2nd Dropdown -

  <label>Select a test id</label>
  <selectFirstChoice>true</selectFirstChoice>
  <prefix>test_id="</prefix>
  <suffix>"</suffix>
  <default>*</default>
  <choice value="*">ALL</choice>
  <populatingSearch fieldForValue="test_id" fieldForLabel="test_id" earliest="0" latest="now">
    <![CDATA[index=XXX version=$version01$ | stats count by test_id]]>
  </populatingSearch>
</input>

bryanit715
Engager

hmm did you ever solve your issue? I actually am running in to the exact same thing

0 Karma

knutsod
Path Finder
0 Karma

kallisrayar1986
Path Finder

It did not help, the problem occurs when i select some other value in the first dropdown, the second drop value remains unchanged even though the second drop down search is executed and populated behind the screen.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...