Dashboards & Visualizations

Multi search Dashboard panel

tkerr1357
Path Finder

Hello,

I would like to make a dashboard panel that is a table the shows total successful logins in one row and total failed logins in another row. The base search for both is index=myindex Eventcode=4624(successful) host=myhost1 user=user* | stats count , index=myindex EventCode=4625(failed) host=myhost1 user=user* | stats count. Can anyone help me with how I would display these separate searches in a single dashboard panel?

Labels (2)
0 Karma

niketn
Legend

@tkerr1357 don't introduce subsearch for the query as you can handle straightforward using a query like the following:

Eventcode=4624 ("successful" OR "failed") host=myhost1 user=user* 
| stats count(eval(searchmatch("successful"))) as successful  count(eval(searchmatch("failed"))) as failed

The above search will make single trip to fetch required data from Index and will not be impacted by subsearch limitation. Please try out and confirm! 

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

impurush
Contributor

Hi @tkerr1357 

Use the append command to do that.

index=myindex Eventcode=4624(successful) host=myhost1 user=user* | stats count
|append [search index=myindex EventCode=4625(failed) host=myhost1 user=user* | stats count]
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...