Dashboards & Visualizations

Modifying searches to exclude IP address

Ted1621
Observer

How would I modify this search :

| tstats prestats=true summariesonly=true allow_old_summaries=true count from datamodel=Authentication.Authentication where Authentication.app=win* Authentication.action=$action$ by _time, Authentication.user span=10m
| timechart minspan=10m useother=true count by Authentication.user limit=50

to exclude this IP Address: src_ip!="10.0.1.90"

Labels (2)
0 Karma

Ted1621
Observer

This did not seem to work I still see the failed logins from this source...

| tstats prestats=true summariesonly=true allow_old_summaries=true count from datamodel=Authentication.Authentication where Authentication.app=win* Authentication.action=$action$ Authentication.src_ip!="10.0.1.90" by _time, Authentication.user span=10m
| timechart minspan=10m useother=true count by Authentication.user limit=50

0 Karma

bowesmana
SplunkTrust
SplunkTrust

How can you see that there are failed logins from this source? You tstats will only give you count, _time and user.

If you also split by the IP and don't do the timechart, can you see 10.0.1.90 as a src/src_ip?

Does your Authentication DM contains src_ip as opposed to just src?

0 Karma

bowesmana
SplunkTrust
SplunkTrust

I believe src is the field in the datamodel that contains the ip - so just add the constraint to the existing where clause

| tstats prestats=true summariesonly=true allow_old_summaries=true count from datamodel=Authentication.Authentication where Authentication.app=win* Authentication.action=$action$ Authentication.src!="10.0.1.90" by _time, Authentication.user span=10m
| timechart minspan=10m useother=true count by Authentication.user limit=50
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: The Agentic SOC: Trust Before Autonomy

AI is fundamentally changing security operations, but true progress requires more than just automation—it ...

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...