Dashboards & Visualizations
Highlighted

Jenkins dashboard load delay

Explorer

Hi,

We installed and configured the Splunk app for Jenkins couple of weeks ago.

The app works very good, all the data come and fill the dashboards, and also the DevOps guys are mentioned that it opens new and better visibility on what is going on their Jenkins environment.

Nevertheless, there is one big issue - the dashboards load in delay of 15 sec! Just after this the panels shows and the dashboard fill.

We tried it on several environments but unfortunately it's the same behavior - for every dashboard there is delay of 15 sec.

I guess it something with the fact the is it HTML dashboard (not XML) and maybe wait for something 15 sec - something that I don't know what is it.

I hope someone can help with that.

Thanks,

Omer Rudik.

0 Karma
Highlighted

Re: Jenkins dashboard load delay

Splunk Employee
Splunk Employee

The first load time is pretty slow, there are many small javascript files to be loaded, however such javascript files will be cached in browser and will not be loaded again, from the splunk response

Cache-Control:public, max-age=31536000
Content-Encoding:gzip
Content-Length:6997
Content-Type:text/javascript;charset=utf-8
Date:Wed, 05 Apr 2017 14:14:41 GMT
ETag:"C00EFF7CF16238A69C71DA753D80DFDABF79A683"
Expires:Wed, 05 Apr 2018 14:14:41 GMT
Last-Modified:Tue, 04 Apr 2017 06:08:58 GMT
Server:Splunkd
Vary:Accept-Encoding
X-Content-Type-Options:nosniff

If you experience the slow loading issue every time, is it possible that you are using a proxy server which does not send cache-control and Etag?

0 Karma
Highlighted

Re: Jenkins dashboard load delay

Explorer

Hi,

thanks for the answer.

we have the same as you but have also those rows:

cache-control: no-cache
pragma: no-cache
x-frame-optiobs: sameorigin

You maybe know what that is means? (or if it should appear)

Thanks,

Omer.

0 Karma
Highlighted

Re: Jenkins dashboard load delay

Splunk Employee
Splunk Employee

I don't have much information about your deployment, it maybe caused by proxy or load balancer.
If you are accessing splunk web through reverse proxy or load balancer, you need enable Cache.

0 Karma