Dashboards & Visualizations

How to make Splunk Dashboard for creating panels inside grid?

Atchyuth_P
Path Finder

Hi Team,

I would like to achieve the below dashboard which is having outer grid and inside we have multiple panels.

Atchyuth_P_0-1683142803339.png

Please check with the XML code

Atchyuth_P_1-1683142863350.png

Kindly help in achieving this.

Labels (2)
Tags (1)
0 Karma

Atchyuth_P
Path Finder

<form version="1.1" theme="dark">
<label>Windows Testing</label>
<fieldset submitButton="false">
<input type="time" token="time" searchWhenChanged="true">
<label>Select Time Ranage</label>
<default>
<earliest>0</earliest>
<latest></latest>
</default>
</input>
</fieldset>
<row>
<panel>
<title></title>
<html>
<div>
<h2>Successful Authentications</h2>
</div>
<style>
h2 {
text-align: center;
background-color:gray ;
border: 1px solid black;
border-radius: 25px;
}
.dashboard-panel {
background-color: #177843;
border-radius: 25px;
border: 2px solid #73AD21;
}
.dashboard-panel:hover {
transform: scale(0.95);
}
</style>
</html>
<single>
<search>
<query>| tstats count from datamodel=Authentication.Authentication where Authentication.EventCode=4624</query>
<earliest>$time.earliest$</earliest>
<latest>$time.latest$</latest>
<sampleRatio>1</sampleRatio>
</search>
<option name="drilldown">none</option>
<option name="rangeColors">["0x53a051","0x0877a6","0xf8be34","0xf1813f","0xdc4e41"]</option>
<option name="refresh.display">progressbar</option>
</single>
</panel>
<panel>
<title></title>
<html>
<div>
<h2>Failed Authentications</h2>
</div>
</html>
<single>
<search>
<query>| tstats count from datamodel=Authentication.Authentication where Authentication.EventCode=4625</query>
<earliest>$time.earliest$</earliest>
<latest>$time.latest$</latest>
</search>
<option name="drilldown">none</option>
<option name="refresh.display">progressbar</option>
</single>
</panel>
<panel>
<html>
<div>
<h2>User Account Created</h2>
</div>
</html>
<single>
<search>
<query>| tstats count from datamodel=Authentication.Authentication where Authentication.EventCode=4720</query>
<earliest>$time.earliest$</earliest>
<latest>$time.latest$</latest>
</search>
<option name="drilldown">none</option>
<option name="refresh.display">progressbar</option>
</single>
</panel>
<panel>
<html>
<div>
<h2>Account Lockout</h2>
</div>
</html>
<single>
<search>
<query>| tstats count as "Accounts Created" from datamodel=Authentication.Authentication where Authentication.EventCode=4740</query>
<earliest>$time.earliest$</earliest>
<latest>$time.latest$</latest>
</search>
<option name="drilldown">none</option>
<option name="refresh.display">progressbar</option>
</single>
</panel>
</row>
</form>

Kindly check with source code

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...