Dashboards & Visualizations

How to load a scheduled report in a dashboard panel based on the value of a drop-down form?

Explorer

I have a dashboard with a drop down form field which is populated using a search. I want the panels in the dashboard to load scheduled reports based on the value selected in the drop down. Tried the following but it doesn't seem to be working.

<form>
  <label>....</label>
  <fieldset submitButton="false">
    <input type="dropdown" token="product">
      <search>
        <query>...</query>
      </search>
      <fieldForLabel>....</fieldForLabel>
      <fieldForValue>....</fieldForValue>
    </input>
  </fieldset>
  <row>
    <panel>
      <table>
        <title>....</title>
        <search ref="$product$-XYZ"></search>
      </table>
    </panel>
  </row>
... more panels that use $product$
</form>
0 Karma
1 Solution

Influencer

Depending on your version of Splunk (given that you're using the newer search element syntax, i suspect you're ok), but one option may be to use changed conditions, to show/hide different panels as described in an unset example in the docs: http://docs.splunk.com/Documentation/Splunk/6.2.0/Viz/PanelreferenceforSimplifiedXML#unset (they're using a drilldown instead of an input changed, but same principle)

Another option may be instead of a search ref, have a search string that uses either the loadjob or savedsearch command instead. Check the docs for syntax, but string substitutions should work there.

View solution in original post

Influencer

Depending on your version of Splunk (given that you're using the newer search element syntax, i suspect you're ok), but one option may be to use changed conditions, to show/hide different panels as described in an unset example in the docs: http://docs.splunk.com/Documentation/Splunk/6.2.0/Viz/PanelreferenceforSimplifiedXML#unset (they're using a drilldown instead of an input changed, but same principle)

Another option may be instead of a search ref, have a search string that uses either the loadjob or savedsearch command instead. Check the docs for syntax, but string substitutions should work there.

View solution in original post