Dashboards & Visualizations

How to get a populatingSearch to dynamically populate a drop-down menu?

cjrash1
Engager

All -

I have been trying to implement the findings from a few other posts, but I just cannot get this figured out. I am trying to populate a drop-down based on active DHCP requests. I can get the list of IPs with this search:

index=bro sourcetype=bro_dhcp | sort by src_ip | dedup src_ip | table src_ip

BUT I cannot get it to implement in the drop-down menu.

I have done massive amounts of deleting, and this is what I am left with:

  <label>DNS Requests By IP</label>  
  <fieldset submitButton="false" autoRun="false">
    <input type="dropdown" token="inIP">
    <label>Current DHCP Leases: </label>
      <populatingSearch fieldForValue="src_ip" fieldForLabel="src_ip">
        sourcetype=bro_dhcp | fields src_ip | dedup src_ip
      </populatingSearch>
 </input> 
  </fieldset>
</form>

Any help would be amazing.

0 Karma
1 Solution

sundareshr
Legend

Try this

<label>DNS Requests By IP</label>
<fieldset submitButton="false" autoRun="false">
    <input type="dropdown" token="inIP">
        <label>Current DHCP Leases: </label>
        <search>
        <query>
           sourcetype=bro_dhcp | fields src_ip | dedup src_ip
        </query>
        </search>
        <fieldForLabel>src_ip</fieldForLabel>
        <fieldForValue>src_ip</fieldForValue>
    </input>
</fieldset>
</form>

View solution in original post

sundareshr
Legend

Try this

<label>DNS Requests By IP</label>
<fieldset submitButton="false" autoRun="false">
    <input type="dropdown" token="inIP">
        <label>Current DHCP Leases: </label>
        <search>
        <query>
           sourcetype=bro_dhcp | fields src_ip | dedup src_ip
        </query>
        </search>
        <fieldForLabel>src_ip</fieldForLabel>
        <fieldForValue>src_ip</fieldForValue>
    </input>
</fieldset>
</form>

cjrash1
Engager

Awesome. I only had to make one edit and it worked. Added the index into the search
index=bro sourcetype=bro_dhcp earliest=-7d| fields + src_ip | dedup src_ip | sort by src_ip

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...