Dashboards & Visualizations

How to exclude equal values in different columns

reneedeleon
Engager

How to exclude equal values in different columns to obtain stats with different values only? I want to exclude similarities to list only where the user and sysuser are different.

index=example* stuff
| stats count by user, sysuser

*user **sysuser
Bill Bill
Steve Steve
*Dave Jon
Vince Daniel

Any Ideas?

Tags (1)
0 Karma

kmaron
Motivator
index=example* stuff
| stats count by user, sysuser
| where user!=sysuser
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...