Dashboards & Visualizations

How to add a searchbox to a dashboard?

jrevolorio
Explorer

I've created a dashboard that can help find users based of IP or Host. How do I add a searchbox to this dashboard so I can just enter either a username or IP and find their information? Thanks!

My search: sourcetype=WinEventLog:Security user=* src_nt_host=* | table _time, src_ip user, src_nt_host, host

Each time I try to add an input (text) to do a search for an ip or host it doesn't run the search, not sure if I entered the token correctly? Please advise! Thanks!

Tags (3)
0 Karma
1 Solution

somesoni2
Revered Legend

This is one of the basic Splunk form/dashboard example. What you need is to add the token name that you specified in Textbox in your search. You can use the example show here as reference (the example uses dropdown but token usage will be same)

http://docs.splunk.com/Documentation/Splunk/6.5.1/Viz/Buildandeditforms#Basic_form_example

Another good sources of getting examples of various types/usage of Splunk dashboards is https://splunkbase.splunk.com/app/1603/

View solution in original post

niketn
Legend

@jrevolorio, would it be possible to share the code for your textbox input? Also how you are using the token in your search?

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

somesoni2
Revered Legend

This is one of the basic Splunk form/dashboard example. What you need is to add the token name that you specified in Textbox in your search. You can use the example show here as reference (the example uses dropdown but token usage will be same)

http://docs.splunk.com/Documentation/Splunk/6.5.1/Viz/Buildandeditforms#Basic_form_example

Another good sources of getting examples of various types/usage of Splunk dashboards is https://splunkbase.splunk.com/app/1603/

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...