Dashboards & Visualizations

Dashboard for Wineventlogs with Inbuilt Information

anandhalagaras1
Contributor

Hi Team, 

I have created a dashboard with the below mentioned query and the output would be in Column chart format with a timer. And the output would display the Top 10 Event Codes with Count when we choose the time and click submit.

index=windows host=* source=WinEventLog:System EventCode=* Type=Error OR Type=Critical | stats count by EventCode Type |sort -count | head 10

So post the results are displayed in the Column chart then my requirement is that if we click any one of the EventCode  consider as an example of 4628 from the Top 10 details in the Column Chart then it should  navigate to a new panel or a window showing up with the Top 10 host, source, Message, EventCode along with Count for Event Code 4628. So something like that we want to get the results displayed. 

But this should happen if we click the EventCode from the Column chart of the existing dashboard.

Example:

index=windows host=* source=WinEventLog:System EventCode=4628 Type=Error OR Type=Critical | stats count by host source Message EventCode |sort -count | head 10

 

So kindly let me know how to achieve this requirement in a dashboard format.

 

Labels (4)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @anandhalagaras1,

you should install in your Splunk the Splunk Dashboard Examples App (https://splunkbase.splunk.com/app/1603).

One of the examples is just what you're searching: the In page Drilldown.

Ciao.

Giuseppe

0 Karma

Sailesh6891
Engager

Page not found for the link.

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...