Dashboards & Visualizations

Active vs Inactive Users in a Timechart

rajkskumar
Explorer

I have a chart that displays the Active and Inactive Users for today. I would like to convert this into a timechart which shows data for the selected Period in the Time picker. 

 

index=prod 
       | stats latest(_time) as last_seen by customerId 
       | eval status = if(last_seen > relative_time(now(), "-30d@d"),"Active","Inactive") 
       | chart count by status
       | rename count as "User Count"

 

Please suggest how it could be approached.

@FrankVl : You have helped me with the original query. Could you please guide me here as well?

Labels (1)
0 Karma

FrankVl
Ultra Champion

One way to do that would be to run the search you have, that gives you today's figures, on a daily basis and write the results into a summary index. Then run a timechart over that summary index. But of course, that does require some time to build up data in the summary index before you're able to timechart anything.

Creating a query that directly gives you a timechart of active and inactive users by day is a bit more tricky as that activity is based on a 30d window.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Replacing chart with timechart should do it.

---
If this reply helps you, Karma would be appreciated.
0 Karma

rajkskumar
Explorer

Unfortunately, it is not working. I don't get any results with Timechart. With 'Chart', I get the Active and Inactive count for today.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...