Dashboards & Visualizations

0 instead empty

jip31jip31
Explorer

hi

i use this request in a Dashboard
but when the result = 0 i dont have 0 displaying but Nothing
i would like to ,have 0
how to do please?
thanks

index="*" DisplayName="PCServicesWinSrv" Started="false" State="Stopped" | dedup host | stats count by DisplayName | eventstats sum(count) as Total | eval percent=round((count/Total)*100,1) | eval DisplayName=DisplayName."(count: ".count.", percent: ".percent.")" | table count

Tags (1)
0 Karma
1 Solution

krishnab
Path Finder

Hi it is simple try this,

your search
| eval count=if(isnull(count),"0",count)
| table count

View solution in original post

0 Karma

jip31
Motivator

thank you very much

0 Karma

jip31
Motivator

thanks a lot!!!!!!

0 Karma

niketn
Legend

@jip31 if one of the answers has helped you, please do not forget to accept the same to mark this question as answered!

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

Sukisen1981
Champion

Splunk gives you the fillnull function to do this instead of writing an eval statement(which also should work) -

your search | fillnull value=0 count
0 Karma

krishnab
Path Finder

Hi it is simple try this,

your search
| eval count=if(isnull(count),"0",count)
| table count

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...