Archive
Highlighted

Splunk DBX v1.0.9 Java Bridge Server not running

Explorer

Greetings Splunk Answers,

I recently upgraded from Splunk DB Connect 1.0.8 to 1.0.9 and am now experiencing an issue where the Java Bridge Server stays in a "loading" state. I don't utilize search head pooling in my env.

I don't see the 'Splunkd REST Keep-alive' entries in the dbx.log.
I am seeing numerous entries where the BridgeSession continually executes...but successfully. status=0 ...?

dbx.log:
2013-05-08 22:28:03.665 dbx6779:INFO:BridgeSession - Executing Bridge command: BridgeExecutionInfo{className=com.splunk.bridge.cmd.Reload}
2013-05-08 22:28:03.665 dbx6779:INFO:Reload - Reloading component=dbmon
2013-05-08 22:28:03.666 dbx6779:INFO:BridgeSession - Execution finished in duration=1 ms with status=0
2013-05-08 22:28:03.666 dbx6779:INFO:ExecutionContext - Execution finished in duration=2 ms

I'm not seeing any issues with in the jbridge.log file.

jbridge.log:
2013-05-08 21:00:09,055 DEBUG starting pid watcher...
2013-05-08 22:25:55,240 DEBUG cleanup callback... termingating process
2013-05-08 22:25:55,240 DEBUG sending shutdown command to jbridge server
2013-05-08 22:25:55,240 DEBUG Running btool for 'java.conf'.
2013-05-08 22:26:57,064 DEBUG Setting up Java Environment: app=dbx, cfgname=java, cfgstanza=java, javahome=None
2013-05-08 22:26:57,357 DEBUG JAVA
HOME=/usr/jre/jdk1.7.021/
2013-05-08 22:26:57,358 DEBUG options=['-Xmx256m', '-Dfile.encoding=UTF-8', '-server', '-Duser.language=en', '-Duser.region=', '-Dsplunk.app.ctx=dbx']
2013-05-08 22:26:57,358 INFO Checking for obsolete java libraries in /opt/splunk/etc/apps/dbx/bin/lib
2013-05-08 22:26:57,358 DEBUG Starting JavaBridgeServer...
2013-05-08 22:26:57,358 DEBUG Executing (native) CMD /usr/jre/jdk1.7.0
21/bin/java -cp /opt/splunk/etc/apps/dbx/bin/lib/jdbm-2.2.jar:/opt/splunk/etc/apps/dbx/bin/lib/commons-logging-1.0.4.jar:/opt/splunk/etc/apps/dbx/bin/lib/dbx.jar:/opt/splunk/etc/apps/dbx/bin/lib/mysql-connector-java-5.1.24-bin.jar:/opt/splunk/etc/apps/dbx/bin/lib/xstream-1.4.1.jar:/opt/splunk/etc/apps/dbx/bin/lib/sqlite-jdbc-3.7.2.jar:/opt/splunk/etc/apps/dbx/bin/lib/stringtemplate-3.2.1.jar:/opt/splunk/etc/apps/dbx/bin/lib/hsqldb.jar:/opt/splunk/etc/apps/dbx/bin/lib/antlr-2.7.7.jar:/opt/splunk/etc/apps/dbx/bin/lib/log4j-1.2.15.jar:/opt/splunk/etc/apps/dbx/bin/lib/h2-1.3.162.jar:/opt/splunk/etc/apps/dbx/bin/lib/jtds-1.2.6.jar:/opt/splunk/etc/apps/dbx/bin/lib/commons-pool-1.5.6.jar:/opt/splunk/etc/apps/dbx/bin/lib/postgresql-9.0-801.jdbc3.jar -Xmx256m -Dfile.encoding=UTF-8 -server -Duser.language=en -Duser.region= -Dsplunk.app.ctx=dbx com.splunk.bridge.JavaBridgeServer 30254
2013-05-08 22:26:57,390 INFO Started JavaBridgeServer PID=30272

I suppose the answer lies in why I'm getting numerous BridgeSession executions...but I'm not sure.
Can anyone help with this?

Thanks,
ktang

0 Karma
Highlighted

Re: Splunk DBX v1.0.9 Java Bridge Server not running

Splunk Employee
Splunk Employee

This looks like the Java Bridge started up successfully. Where are you seeing it in a "loading" state? It is normal to have multiple Execution sessions. What do you see when you go to the status page here: http://localhost:8000/en-US/app/dbx/dbxstatus

0 Karma
Highlighted

Re: Splunk DBX v1.0.9 Java Bridge Server not running

Explorer

This issue was resolved by resetting the db password in the database.conf file.

ref:
http://splunk-base.splunk.com/answers/77008/java-birdge-server-not-running-in-splunk-db-connect

View solution in original post

Highlighted

Re: Splunk DBX v1.0.9 Java Bridge Server not running

Path Finder

I have a similar problem .... dbx version 1.1.2 ....
The page sits there and flashes .... "Java Server Bridge is loading".

Any suggestions?

0 Karma
Highlighted

Re: Splunk DBX v1.0.9 Java Bridge Server not running

In my case, I found "The Java Bridge is loading" when I select wrong Role Permission.

In conclusion, DO NOT select EVERYONE in APP Permission Role & select ONLY "This APP ONLY" in Sharing for config file-only objects

0 Karma
Highlighted

Re: Splunk DBX v1.0.9 Java Bridge Server not running

Communicator

Killing Java PID did the trick for me.

0 Karma