All Apps and Add-ons

install add-on: Error connecting to /services/apps/local: The read operation timed out

johnoke
Explorer

Ubuntu 18.04.4 LTS trying to install Python for Scientific Computing (for Linux 64-bit). I've seen other similar questions but no answers. this is Splunk Enterprise
Version:
8.0.2.1
Build:
f002026bad55

1 Solution

johnoke
Explorer

Yes it is. Actually got this to work from splunk web just by searching and installing from the manage apps page. The error was received after I downloaded and tried to install from file. Acceptable workaround for now.

View solution in original post

hettervik
Builder

For me it worked just refreshing the page and trying again. Looks like the server can timeout if it's busy or something. Know I'm late to the party here, but posting it in case someone else is having the same problem.

0 Karma

vgtk4431
Path Finder

You should increase the timeout in the web.conf


[settings]
splunkdConnectionTimeout = 300

vulnfree
Explorer

web.conf were? Are you referring to /opt/splunk/etc/system/local/web.conf or web.conf in the AWS app?

0 Karma

johnoke
Explorer

Yes it is. Actually got this to work from splunk web just by searching and installing from the manage apps page. The error was received after I downloaded and tried to install from file. Acceptable workaround for now.

rootmx
Engager

Works on windows to, thanks for the Tip, I was start to loose my mind

0 Karma

jkat54
SplunkTrust
SplunkTrust

Is port 8089 open?

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...