All Apps and Add-ons

error while loading shared libraries: libmcrypt.so.4: cannot open shared object file: No such file or directory when running Splunk for Nagios

cdurland
Engager

Hey Luke,

Our installation is trying to send splunk alerts to nagios(basically just using nagios as a front end). The issue I'm having is that on our splunk server(64bit centos 6), we keep seeing this issue:

$ sudo ./send_nsca localhost -c /home/testuser/nsca.cfg < test.txt
./send_nsca: error while loading shared libraries: libmcrypt.so.4: cannot open shared object file: No such file or directory

I've installed the most recent mcrypt(and libmcrypt) package, and ive even tried using older versions. I'm still getting this error. Have you see this before?

Tags (1)
0 Karma
1 Solution

cdurland
Engager

Just to update: You need to use the 32-bit version of libmcrypt for this to work. Pointing it to the 64bit version throws an error, but the 32-bit works flawlessly.

View solution in original post

0 Karma

cdurland
Engager

Just to update: You need to use the 32-bit version of libmcrypt for this to work. Pointing it to the 64bit version throws an error, but the 32-bit works flawlessly.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...