All Apps and Add-ons
Highlighted

collapsing threshold in donut chart

Explorer

Hi Splunkers,

I have a use case where in I am plotting count against users with donut. Now, the issue is: for values < 99%, we get an "OTHER" slice. I need the complete dataset, no "other" slice. tried collapsing threshold with the visualisation, even limit=0 does not work for me. Any pointers would be highly appreciated.

Best,

0 Karma
Highlighted

Re: collapsing threshold in donut chart

Motivator

you can remove the "OTHER" from the results with "useother=f",

e,g.

| timechart span=1d sum(field1) AS sumfield1 by field2 useother=f fixedrange=false

0 Karma
Highlighted

Re: collapsing threshold in donut chart

New Member

Adjust the formatting of the visualization in version 1.0.3 (or higher) which was recently uploaded to Splunkbase. For the “Use Min Percent” setting change it from Yes to No. This will disable the Min Percent setting and display all of the results from the search as slices in the Donut visualization. Depending on the data, this may result in a very noisy visualization.

Another method, which doesn't sound like it would be an option in this particular case but others may find useful, is to use the ‘top’ search function as a part of the original search. If your search is, for instance, "index=main | chart count(source) by source”, consider changing it to "index=main | chart count(source) by source|top limit=12 source”. The latter search will only display the top 12 results in the search and eliminate the OTHER slice from appearing. The limit setting must be at least 1 less than the amount of results that causes the OTHER slice to appear, so it may take some adjusting to get the OTHER slice not to appear. This will mean that you do not see the results of the lowest number of results from your search reflected in any way in the visualization, but will potentially be less noisy than eliminating the min percent setting.

Hope this helps.

0 Karma