All Apps and Add-ons

basic http status query (404 error 200 success)

nathanluke86
Communicator

I would like to show http traffic from my f5 (load balancer) to web servers for statuses 200 and 404 (200 green, 404 red). As a basic example something like this:

index = iis
| stats sum(eval(status="404")) as error sum(eval(status="200")) as success by dest_ip
|eval from="f5" , to=dest_ip
|head 100
|table from to success error

I can't seem to get the flows working. I have changed names to match error, warn, good but have not had much success.

any pointers would be appreciated.

please feel free to expand on this query to add more value. My aim is to visualize traffic flows to show when there are issues etc

0 Karma
1 Solution

chrisyounger
SplunkTrust
SplunkTrust

Hi @nathanluke86

Thanks for using my Viz. This query should work:

index = iis
| stats count(eval(status="404")) as error count(eval(status="200")) as good by dest_ip
|eval from="f5" , to=dest_ip
|head 100
|table from to good error

View solution in original post

chrisyounger
SplunkTrust
SplunkTrust

Hi @nathanluke86

Thanks for using my Viz. This query should work:

index = iis
| stats count(eval(status="404")) as error count(eval(status="200")) as good by dest_ip
|eval from="f5" , to=dest_ip
|head 100
|table from to good error

nathanluke86
Communicator

Thanks, this worked perfectly

0 Karma

hychen1116
New Member

Hi,
I'd like to show near real time web traffic without refresh dashboard,
any pointers would be appreciated.

0 Karma

nathanluke86
Communicator

Is there also a way to display Success instead of good

0 Karma

chrisyounger
SplunkTrust
SplunkTrust

at the end of your query, add this:

| eval label = "Success: " + good + " Error: " + error
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...

Where Innovation Takes Flight: The Splunk4Aviation Flight Sim Lands at .conf26

If you hear someone at .conf26 shouting "gear down, GEAR DOWN" across the show floor, you have found us.  The ...

Turn Cisco Telemetry Into Action with Cisco Data Fabric, powered by the Splunk ...

The surge in machine data is already hitting enterprise budgets, and the agentic era will only intensify it. ...