All Apps and Add-ons

Why are we unable to connect to Netezza using Splunk DB Connect and Splunk 6.5.0 with error "Failed to get driver instance..."


The error we are getting:

Exception: java.lang.RuntimeException: Failed to get driver instance for jdbcUrl=jdbc:netezza://
2016-10-05T10:43:10-0400 [ERROR] [], line 225: exception java.lang.RuntimeException: Failed to get driver instance for jdbcUrl=jdbc:netezza://

The Netezza stanza in the connection_type.conf

displayName = Netezza
serviceClass = com.splunk.dbx2.postgres.PostgresJDBC
jdbcUrlFormat = jdbc:netezza://:/
jdbcDriverClass = org.netezza.Driver

The driver is in the

Successfullly tested the jdbc using java command.

Any insight anyone can offer is greatly appreciated.



I fixed the problem as follows:

I upgraded from jre7 to jre8 (you're probably already correctly on jre8), got the same error message in the original question here except with sqlserver, tried reloading drivers, still got the same message. Then I looked in /home/splunk/etc/apps/splunk_app_db_connect/bin/lib and the only driver was rpcserver-all.jar. I downloaded sqljdbc42.jar from Microsoft (, again, this was for my case using sqlserver), and then reloaded drivers, and restarted the RPC server again, and that fixed the error! (I'm getting a separate error now, but fixed the error message that this question refers to)


we have the similar issue with Splunk 6.5.1 and Splunk DB Connect v.2.4.0. We can connect and make queries to Netezza but occasionally we get the same issue. To solve it we have to run the "reload" button in the Settings-Drivers tab.

Our config in db_connection_type.conf is slightly different:

displayName = IBM Netezza
serviceClass = com.splunk.dbx2.DefaultDBX2JDBC
jdbcUrlFormat = jdbc:netezza://:/
jdbcDriverClass = org.netezza.Driver

supportedVersions = 7.0

database = testDB
port = 5480
testQuery = SELECT 1 AS test

0 Karma


our driver file is "nzjdbc3.jar".

0 Karma

Path Finder

We're seeing the same issue. When in the UI, the validation fails when loading the driver. The same workaround of going to the Settings and Reloading the drivers temporarily allowing the connection to be completed or a query setup.

0 Karma


any idea on how to call this "Reload" maybe via REST API? We could the automate the workaround via alert+script! We already have an alert to warn us of this error...

0 Karma

Splunk Employee
Splunk Employee

that looks like Java won't load the driver, could be incompatible, or it could be a permissions thing

0 Karma


I am having the same issue. Wouild really appreciate any help...
java.lang.RuntimeException: Failed to get driver instance for jdbcUrl=jdbc:netezza://ip:port/database

New Member

No insight but I have the same problem, different JDBC driver. I seem to be able to make JDBC work in other tools, but I have failed to get one added into Splunk (6.5.1) yet.


0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...