All Apps and Add-ons

Why am I unable to add custom navigation menus to the Cisto eStreamer for Splunk app?

Communicator

In the past I've successfully added custom navigation menus to a variety of Splunkbase and custom apps with no problem, but when I attempt to do the same in the Cisco eStreamer for Splunk app, the XML changes aren't taking.

It's a fairly simple change... I'm adding these lines via the web-interface with admin credentials:

<collection label="<business unit> Reports">
        <saved source="all" match="<business unit>" />
</collection>   

I've verified that the change is present in: /HOME/apps/eStreamer/local/data/ui/nav/default.xml

And since we have a search head cluster, I've also verified that the changed have replicated to all the nodes.

Anyone have any ideas why this app won't take the change when others have?

0 Karma
1 Solution

Communicator

Never mind... this was a user error... every other time I'd created a new navigation menu I'd already had content saved that met the "match" criteria. This time I was creating the menu in anticipating needing a spot to place content that hadn't yet been saved.
As soon as I saved my first search with the "match" criteria, the menu displayed.

Didn't realize that the XML wouldn't pre-populate the collection information without content.

View solution in original post

0 Karma

Communicator

Never mind... this was a user error... every other time I'd created a new navigation menu I'd already had content saved that met the "match" criteria. This time I was creating the menu in anticipating needing a spot to place content that hadn't yet been saved.
As soon as I saved my first search with the "match" criteria, the menu displayed.

Didn't realize that the XML wouldn't pre-populate the collection information without content.

View solution in original post

0 Karma