All Apps and Add-ons
Highlighted

Why am I receiving the following Collections.conf and Drilldown_settings warning messages after installing the Alert Manager App?

Engager

Hello,

After installing the new Alert Manager app, I received the following message in Splunkd.log

"MongoModificationsTracker - Could not load configuration for collection 'drilldown_settings' in application 'alert_manager'. Collection will be ignored."

This is because there isn't a stanza value in the collections.conf titled drilldown_settings, as well as no key value pairs. I've disabled the collections within lookups so the error no longer fires.

Is this something that was missed by the App author?

Is drilldownsettings remnants from the older version of alertmanger?

If you repaired this within collections.conf could you be specific about where you find the information? (ie which Python script and where at in the Python script),Hello,

Tags (1)
Highlighted

Re: Why am I receiving the following Collections.conf and Drilldown_settings warning messages after installing the Alert Manager App?

Communicator

When creating the collection definition in /opt/splunk/etc/apps/alert_manager/default/transforms.conf for the alertmanager splunk app, the author/s were not uniform in listing the fields for the **'drilldownsettings'** collection, and that creates the error you're witnessing in your splunkd.log file.

To fix the issue, just put a space between the comman (,) and field name "label" in the fields_list parameter

ORIGINAL DEFINITION LOOKS AS FOLLOWS:

[drilldownsettings]
external
type = kvstore
collection = drilldownsettings
fields
list = _key, type,label, search, field, disabled, comment

AFTER EDITING THE DEFINITION, IT SHOULD LOOK AS FOLLOWS

[drilldownsettings]
external
type = kvstore
collection = drilldownsettings
fields
list = _key, type, label, search, field, disabled, comment

I hope that helps.

Highlighted

Re: Why am I receiving the following Collections.conf and Drilldown_settings warning messages after installing the Alert Manager App?

Engager

i found another solution that you change configuration in $SPLUNKHOME/etc/apps/alertmanager/default/collections.conf , then add text below in bottom of the files

[drilldown_settings]
enforceTypes = true
field.type = string
field.field = string
field.disabled = bool
field.label = string
field.search = string

field.comment = string

save its and restart splunk service, after that the WARNING is nothing 😄

reference change from github:
https://github.com/alertmanager/alert_manager/commit/d6b0836579805428217dac2c5b0a5a0e32b4c87f#diff-2...

0 Karma