All Apps and Add-ons

Using the Microsoft Cloud Services Addon with a proxy server

djukicm
Explorer

We are trying to configure the Microsoft Cloud Services addon and are behind an NTLM proxy. From what I can see, the MS account and input are configured fine, however we are getting errors in the splunk_ta_microsoft-cloudservices_azure_audit.log along the following lines and no data is being ingested.

ConnectionError: HTTPSConnectionPool(host='login.microsoftonline.com', port=443): Max retries exceeded with url:

On checking the connections I cannot see this even making connections with our proxy, even though we have configured it via the proxy tab in the addon and is configured normally via the splunk-launch.conf file system wide. For fun I did remove the entries in the addon proxy tab but that made no difference.

Has anyone else seen issues such as this?

Thanks!

asridhara
Explorer

I'm facing the same issue. No resolution

0 Karma

ehaddad_splunk
Splunk Employee
Splunk Employee

have you tried without the global proxy in launch.conf and set this is up only in Add-on? Ive seen issues when you set it up in both.

0 Karma

djukicm
Explorer

Hi Ehaddad,

Thanks for responding.

I'd not tried it that way around but it unfortunately does not make any difference and I still see the same timeout message in the log file

Any other ideas?

.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!