All Apps and Add-ons

Unable to initialize modular input "upload_pcap" after 6.5.2 upgrade

Ultra Champion

I just did my 6.5.1 -> 6.5.2 upgrade and seeing this message on my indexers:

Search peer <hostname_removed_by_sloshburch> has the following message: Unable to initialize modular input "upload_pcap" defined inside the app "splunk_app_stream": Unable to locate suitable script for introspection.

I haven't dug into it yet but figured I'd throw it out there if anyone ran into this as well.

0 Karma
1 Solution

Ultra Champion

I believe I found this to be pinpointed to the issue that apps living in master-apps or slave-apps folders were not being loaded for initialization. I've created a bug to track this behavior.

View solution in original post

Ultra Champion

I believe I found this to be pinpointed to the issue that apps living in master-apps or slave-apps folders were not being loaded for initialization. I've created a bug to track this behavior.

View solution in original post

Do you know what happened to that bug report?, I am seeing the same issue on 6.6.2 (with a different modular input)

0 Karma

Ultra Champion

Fair question. So...I'm on a plane right now, hence no bug ID to provide to you at this time. While it has been addressed for an upcoming build (as in, not yet released) keep in mind the usual legal Safe Harbor that there's no promises and always a chance it doesn't make it. But I'm optimistic and happy with how it was addressed internally. I hope to chime back here once I see the fix roll out (assuming it does). Thanks for checking in.

0 Karma

Splunk Employee
Splunk Employee

perhaps your indexers got a upload_pcap:// stanza in one of the inputs.conf files replicated from the SH? It should be benign though

0 Karma