All Apps and Add-ons

Umbrella Cisco-managed s3 bucket sync only working manually

phamanth
Explorer

Using the details in the cisco umbrella add-on for splunk.  The pull-umbrella-logs.sh runs fine manually as the user, splunk.  The sync will connect and pull logs with no issue.  However, when left to run automated via splunk local inputs.conf.  It cannot connect and fails to ingest any data.  Splunkd log entry:

ERROR ExecProcessor - message from "/opt/splunk/etc/apps/TA-cisco_umbrella/bin/pull-umbrella-logs.sh" fatal error: Could not connect to the endpoint URL

As far as I can tell, splunk should be the using the same user (splunk) in order to run the script automatically.  What might I be missing?

 

Labels (1)
0 Karma
1 Solution

phamanth
Explorer

Figured it out.  Silly mistake of forgetting about script running in a different shell that may or may not have environmental variables for proxy.

View solution in original post

0 Karma

phamanth
Explorer

Figured it out.  Silly mistake of forgetting about script running in a different shell that may or may not have environmental variables for proxy.

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...