All Apps and Add-ons

Tell setup wizard to use python2.7 on Splunk 8.1.1 ?

stwong
Communicator

Hi all,

We upgraded from Splunk 7.3.5 to 8.1.1.     Most of the app/add-on works except one obsoleted one that supports Python2.7 only.   Got error during setup:

 

01-05-2021 14:26:55.771 +0800 ERROR ScriptRunner - stderr from '/opt/splunk/bin/python3.7 /opt/splunk/bin/runScript.py setup':  The script at path=/opt/splunk/etc/apps/TA-ms-loganalytics/bin/TA_ms_loganalytics_rh_log_analytics.py has thrown an exception=Traceback (most recent call last):
01-05-2021 14:26:55.771 +0800 ERROR ScriptRunner - stderr from '/opt/splunk/bin/python3.7 /opt/splunk/bin/runScript.py setup':    File "/opt/splunk/etc/apps/TA-ms-loganalytics/bin/ta_ms_loganalytics/splunktaucclib/rest_handler/endpoint/validator.py", line 389

 

 

As Splunk 8 includes Python 2.7 runtime and binary, possible to tell Splunk to use Python2.7 when handling this app ?

 

Thanks a lot.

Regards

/ST Wong

Labels (2)
0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!