All Apps and Add-ons
Highlighted

Splunk Insights for Infrastructure Unsupported Version of Collectd

Engager

Any idea how to get around the message of " Unsupported version of collectd already installed. Supported versions: 5.7.* or 5.8.* ... "

Running the latest version of SAI with the latest version of Collectd. Do I have to downgrade Collectd? Seems like SAI should support the latest version of Collectd that comes with the brew or yum installer.

0 Karma
Highlighted

Re: Splunk Insights for Infrastructure Unsupported Version of Collectd

Splunk Employee
Splunk Employee

The check for collectd version is placed in the install_agent script. Collectd 5.9 was just released and we haven't yet tested plugin with it. It should mostly work fine though. And , we plan to add support in the next release.

In the meanwhile, you can try :
manual install https://docs.splunk.com/Documentation/InfraApp/1.4.0/Admin/ManageAgents

0 Karma