All Apps and Add-ons

Splunk_DB Connect V3 picks up wrong JAVA_HOME Version

saranya_fmr
Communicator

During the DB Connect install , Splunk picks up the old version as seen below.
This version of 1.7 is set as JAVA_HOME for a different agent (Udeploy agent) installed in the same host.
alt text

We set JAVA_HOME to point to the jdk 1.8u121 in the .bashrc file for the splunk account. But still it picks this old version.

I tried providing the latest version path and clicked on SAVE to restart the task server , but still DB Connect is not up as shown below.

alt text

But a manual restart of splunk on the host fixes this and DB Connect is UP and fine. But as per Splunk doc , we just need to provide the right java path and save . Splunk restart is not required at all.

Firstly , how to make Splunk pick the right JAVA version?

Secondly , why not providing the rigth JAVA PATH and saving it make it work? Why is Splunk resrart required?

Tags (2)
0 Karma

russellliss
Path Finder

Try adding "/jre" to your JAVA_HOME path. From what I have read, it requires a JRE, and not the JDK.

0 Karma

pkeller
Contributor

I had a similar problem and ended up modifying

$SPLUNK_HOME/etc/apps/splunk_app_db_connect/linux_x86_64/bin/customized.java.path which appears to retain whatever path was configured when the app was setup.

I changed the contents to:

/usr/java/latest/bin/java

so it'll cover me the next time I upgrade.

I don't know if this is recommended, but it did work.

0 Karma

sloshburch
Ultra Champion

This appears to be a bug. Look for DBX-4124 in the Release Notes to see when it is updated. In the interim, a restart appears to be the only workaround.

sloshburch
Ultra Champion

@saranya_fmr - Sounds like you did a good job cross checking with the docs but still ran into some break/fix issues. I encourage you to open a support ticket with Splunk. Let's make sure that whatever the root cause gets documented and fixed and the supporting documentation is clear. Cool?

0 Karma

sloshburch
Ultra Champion

Silly me, I see you DID open a support case already! Great job!

0 Karma

niketnilay
Legend

Does the 1.7 Java path existin on your system? Is it required?

Can you check the dbx_settings.conf file for JDK path?

$SPLUNK_HOME/etc/app/splunk_app_db_connect/local

Also based on the OS in your case linux_x86_64\bin,you can check the same folder in DB Connect app's Splunk folder for the path in customized.java.path whether it is JDK 1.8 or 1.7.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

saranya_fmr
Communicator

Yes the 1.7 version is needed for the other version.

After I replace the old 1.7 path with the 1.8 path in the UI and click on Save of Task server settings, the dbx_settings.conf file is reflecting as below.

bash-4.2$ more dbx_settings.conf
[java]
javaHome = /opt/applocal/asts/vendor/java/jdk/jdk1.8.0_121

But still the UI shows the error message "Unable to communicate to task server" and the app is down.

I dont find customized.java.path in any of the files. I only see this commnds.conf. Where do I check for this?
$SPLUNK_HOME/etc/app/splunk_app_db_connect/local/commands.conf
[dbxquery]
filename = customized.java.path

[dbxoutput]
filename = customized.java.path

[dbxlookup]
filename = customized.java.path

0 Karma

niketnilay
Legend

Folder linux_x86_64 should be present at the root path where ever DB Connect 3 is installed in Splunk directory.

$SPLUNK_HOME/etc/app/splunk_app_db_connect/linux_x86_64/bin
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

saranya_fmr
Communicator

yes , it takes 1.8
bash-4.2$ more customized.java.path
/opt/applocal/asts/vendor/java/jdk/jdk1.8.0_121/bin/java
bash-4.2$

0 Karma