All Apps and Add-ons

Splunk DB Connect 2: Metadata configuration problem. Why am I unable to change the index from main?

SplunkTrust
SplunkTrust

I am trying to change the index that the data is going into from DB Connect, but I am unable to change it from main. In the configuration, I change the index in the Metadata section to an existing index, but I get an error when I save the configuration saying "Review this step before saving" and it NEVER saves, even if I hit the save button again.

screen shot

Does anyone know why this is happening, or how to get this to save and work?

This is from the Operations tab, in the DB Inputs side menu option, and the change to the index is the only thing that causes this to fail, so it seems to be related only to that parameter and no other.

0 Karma
1 Solution

SplunkTrust
SplunkTrust

The problem was with the index name. It couldn't have the hyphen/dash (-) in the name, which was strange, since it allowed that index to be created. But now we all know that if this shows up, look for (and remove) any hyphens is the index name.

View solution in original post

SplunkTrust
SplunkTrust

The problem was with the index name. It couldn't have the hyphen/dash (-) in the name, which was strange, since it allowed that index to be created. But now we all know that if this shows up, look for (and remove) any hyphens is the index name.

View solution in original post