All Apps and Add-ons

Splunk DB Connect 2: Compatibility with MS SQL JDBC 4.2

cjj1977
Path Finder

In the documentation for Splunk DB Connect v2.4.0, the only MS SQL JDBC driver mentioned seems to be the older 4.0 version: sqljdbc4.jar. In the documentation for Splunk DB Connect v3.1.0 the recommended MS SQL JDBC driver is version 4.2: sqljdbc42.jar.

http://docs.splunk.com/Documentation/DBX/2.4.0/DeployDBX/Supporteddatabases
http://docs.splunk.com/Documentation/DBX/3.1.0/DeployDBX/Installdatabasedrivers

Does anyone know if the more recent JDBC 4.2 driver works correctly with DB Connect 2.4.0?

I also notice that Microsoft don't seem to support JDBC 4.0 with JRE 1.8:
https://docs.microsoft.com/en-us/sql/connect/jdbc/system-requirements-for-the-jdbc-driver


Motivation: The migration process from 2.4.0 to 3.1.0 simply keeps the same driver, moving it to a new location it seems. This is understandable. I'd like to upgrade the JDBC drivers first, maybe X weeks before migrating the whole app so I don't have to include that in the migration (or back-track if something goes wrong).

0 Karma

cjj1977
Path Finder

In case anyone is wondering, I have been running DB Connect v2.4.0 with JDBC 4.2 on JRE 1.8 for a few weeks now without any problem. I guess that proves that it is compatible, at least well enough for me...

0 Karma
Get Updates on the Splunk Community!

This Week's Community Digest - Splunk Community Happenings [9.26.22]

Get the latest news and updates from the Splunk Community here! Upcoming User Group Events! 👏 Check ...

BSides Splunk 2022 - The Call for Papers is now Open!

TLDR; Main Site: https://bsidessplunk.com CFP Site: https://bsidessplunk.com/cfp CFP Opens: December 15th, ...

Sending Metrics to Splunk Enterprise With the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...