All Apps and Add-ons

Splunk App for Web Analytics: Why can't I enable acceleration for the data model "Web" from the GUI?

bbiandov
Path Finder

I simply can't enable acceleration for the data model "Web" while setting up the Splunk App for Web Analytics? I'm clearly missing something because all documentation points to either a list box with such option under edit or a button next to the phrase "Model is not accelerated" but neither exists?

Thank you

alt text

0 Karma
1 Solution

bbiandov
Path Finder

Well after not getting anywhere with the web GUI as far as being able to enable acceleration I manually edited datamodels.conf and vola, the Web model is now accelerated. It does require splunk restart for the changes to take affect. For path see the docs below:

http://docs.splunk.com/Documentation/Splunk/6.2.5/Admin/Datamodelsconf

alt text

View solution in original post

0 Karma

bbiandov
Path Finder

Well after not getting anywhere with the web GUI as far as being able to enable acceleration I manually edited datamodels.conf and vola, the Web model is now accelerated. It does require splunk restart for the changes to take affect. For path see the docs below:

http://docs.splunk.com/Documentation/Splunk/6.2.5/Admin/Datamodelsconf

alt text

0 Karma

MuS
SplunkTrust
SplunkTrust

Hi bbiandov,

your user account needs to have the accelerate_datamodel capabilities, which is by default only granted to the admin role.

cheers, MuS

0 Karma

bbiandov
Path Finder

Thanks MuS, however I can't edit roles as I'm using the free license.

Funny thing is that other models are enable with acceleration so it isn't that acceleration for data models is not available under free license, I can see them enabled. I just can't figure out how to complete the act of enabling acceleration?

0 Karma