All Apps and Add-ons

Splunk App for GSuite error

Explorer

I have configured both Splunk Gsuite App and Add-on on all-in-one server. But I just received error sourcetype as following:

{"loglevel": "ERROR", "modularinputconsumptiontime": "Tue, 28 May 2019 02:26:17 +0000", "timestamp": "Tue, 28 May 2019 02:26:17 +0000", "errors": [{"inputname": "ga://mydomain", "exceptionarguments": "'NoneType' object has no attribute 'tbframe'", "filename": "ga.py", "msg": "'NoneType' object has no attribute 'tbframe'", "exceptiontype": "AttributeError", "line": 108}]}

Is there anyone has same issue? Please advice how to fix.
Thank you.

0 Karma
1 Solution

Communicator

We ran into similar issues.

The GSuite App and Add-on cannot co-exist at the moment.

Standalone server - Install only the GSuite App and configure

Enterprise Instance

Indexers - Install TA
Search Heads - Unconfigured App (Refer the documentation of the app for search head clustering)
Heavy Forwarder/Collector Node - Install IA and configure.

Hope that helps. Thanks!

View solution in original post

Communicator

We ran into similar issues.

The GSuite App and Add-on cannot co-exist at the moment.

Standalone server - Install only the GSuite App and configure

Enterprise Instance

Indexers - Install TA
Search Heads - Unconfigured App (Refer the documentation of the app for search head clustering)
Heavy Forwarder/Collector Node - Install IA and configure.

Hope that helps. Thanks!

View solution in original post

Explorer

I have followed your guide and it worked correctly.
Thank you for advice.

SplunkTrust
SplunkTrust

Thanks @viksplunk ! Also, @hoangnguyen join us on Slack! splk.it/slack in channel #gsuiteapp if you have more questions!

0 Karma