All Apps and Add-ons

Splunk App for AWS CPU stats collection error with get_ops.py

davidts
Path Finder

Hi,

I have just installed the Splunk App for AWS and I can see my billing information in the dashboards. However, there are two panels that show CPU Utilisation which are showing no results. The app uses a python script, get_ops.py, to collect the CPU stats. When I run the script in terminal I get the following error:

Traceback (most recent call last):
File "./get_ops.py", line 125, in
fOPSTMP.write(dt+' subaccount='+cols[0]+' region='+rn+' instanceid='+iid+' instancetype='+citype+' cpuutilization='+cpu1+' networkin='+ntin1+' networkout='+ntout1+'\n')
NameError: name 'dt' is not defined

Has anyone seen this error before?

0 Karma
1 Solution

ICTMoretonbay
Explorer

Yes I am seeing this as well as a bunch of other errors.

Have you resolved your problem yet?

View solution in original post

0 Karma

aandrieu
Engager

I resolved the problem adding a tab before "fOPSTMP.write" at line 125: this is due to an indentation problem.

0 Karma

ICTMoretonbay
Explorer

Yes I am seeing this as well as a bunch of other errors.

Have you resolved your problem yet?

0 Karma

davidts
Path Finder

Unfortunately I have not manage to fix this issue.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...