All Apps and Add-ons

SPLUNK app for Windows not working

jviteka
Explorer

I am currently having issues with getting my SPLUNK for Windows app to work properly. I have deployed my SPLUNK forwarder to roughly 300 windows boxes but only show a counter performance counter of 2. The Hosts field in Windows shows all 300 servers that I have but the performance does not.

I am trying to search for a specific Windows username that is failing in the Windows Security log but cannot perform this search. If anyone knows an easier way to find the Windows user and events it is tied to I would appreciate it. Also, if there is something wrong with my Windows app please let me know any potential fixes. I am only monitoring the Security eventlog on my Windows boxes. Thanks for the help!

0 Karma
1 Solution

lukejadamec
Super Champion

EventCode 4648 is a success only event, so it will not show failures.
This search for EventCode 4625 will show the stats for the host name where the failure occurred, the username that failed, and the failure reason:

index=main sourcetype="*wineventlog:security" EventCode=4625 | eval Account_Name=mvindex(Account_Name,1) | stats count by Workstation_Name,Account_Name,Failure_Reason

The Account_Name,1 eval statment is used to get the second occurance of Account_Name in the event, because this is generally the name of interest. If you want the first occurrance in the event, then change the 1 to a 0.

View solution in original post

lukejadamec
Super Champion

EventCode 4648 is a success only event, so it will not show failures.
This search for EventCode 4625 will show the stats for the host name where the failure occurred, the username that failed, and the failure reason:

index=main sourcetype="*wineventlog:security" EventCode=4625 | eval Account_Name=mvindex(Account_Name,1) | stats count by Workstation_Name,Account_Name,Failure_Reason

The Account_Name,1 eval statment is used to get the second occurance of Account_Name in the event, because this is generally the name of interest. If you want the first occurrance in the event, then change the 1 to a 0.

jviteka
Explorer

Event ID 4625 and 4648 is what I am looking for with a specified username.

0 Karma

lukejadamec
Super Champion

What EventCode is associated with the failure?

jviteka
Explorer

No I am not collecting data from WMI but I can start. Would you be able to answer the search as a temporary fix in finding all events correlated to a Windows Username?

0 Karma

lukejadamec
Super Champion

The Windows app requires that performace data be collected via WMI. Are you Windows forwarders collecting WMI performace data? You can also configure the Splunk Indexer to collect WMI data from the remote servers, but the service will need to be running as a Windows Domain user.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...