All Apps and Add-ons
Highlighted

SNMP_TA Failed to register transport and run dispatcher: bind()

Builder

Hi All,

I have configured snmpta app to get data from one of the server that runs DCIM solution. I want to collect snmp traps from this server. I created the data input in snmpta as follows, but when I am saving it, it gives below error. Please help resolve the issue ?

02-20-2019 15:16:10.376 +0400 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/snmp_ta/bin/snmp.py" Failed to register transport and run dispatcher: bind() for (u'10.192.245.10', 162) failed: [Errno 99] Cannot assign requested address snmp_stanza:snmp://dcim

my inputs.conf :

[snmp://dcim]
communitystring = public
do_bulk_get = 0
do_get_subtree = 0
index = dcim
ipv6 = 0
snmp_mode = traps
snmp_version = 2C
sourcetype = snmp_ta_dcim
split_bulk_output = 0
trap_host = 10.1.1.15
trap_port = 162
trap_rdns = 0
v3_authProtocol = usmHMACMD5AuthProtocol
v3_privProtocol = usmDESPrivProtocol
mib_names = DCIM_MIB-V2-new
object_names = 1.3.6.1.4.1.2011.2.15.2.4.3.3.0.1

Thanks
PG

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

Builder

@Damien Dallimore - Can you help me resolve the above issue please ? Thanks.

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

New Member

have you fixed this issue?

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

Builder

Can somebody help me to resolve this issue please ?

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

New Member

have you fixed this issue?

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

New Member

Hi ,

Have anybody resolve this issue. I am also getting same error:
message from "python /data/splunk/etc/apps/snmpta/bin/snmp.py" Failed to register transport and run dispatcher: bind() for (u'*', **) failed: [Errno 13] Permission denied snmpstanza:snmp://cisco_prime

Thanks,

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

New Member

have you fixed this issue?

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

New Member

Encounterting this issue too. Does anyone knows how to fix this?

0 Karma
Highlighted

Re: SNMP_TA Failed to register transport and run dispatcher: bind()

Builder

Yes, my issues was fixed. There was a firewall issue (network ports were not opened properly). After fixing that, it started working. Also, I did not use any vendor MIBs, whatever default MIBs was available with Splunk was used.

View solution in original post

0 Karma