All Apps and Add-ons

SA-ModularInput-PowerShell Error

Path Finder

Unable to initialize modular input "powershell2" defined inside the app "SA-ModularInput-PowerShell": Introspecting scheme=powershell2: script running failed (exited with code -532459699).

I don't see any post specific with a clear answer to the above issue. Basically this error will appear in the "Messages" user interface. I don't get many issues that appear in the messages UI but this one repeats often. Along with a answer to this issue can somebody expand on why only certain errors appear in the "Messages" UI and not others?

Also I heard and read that this error can safely be ignored which is fine but it keeps appearing in the messages UI. The perception to the users who see this error over and over and deleting it over and over is not good.

Thanks,

1 Solution

Splunk Employee
Splunk Employee

If this is not a Windows system or the prerequisites haven't been met (http://docs.splunk.com/Documentation/AddOns/latest/MSPowerShell/Hardwareandsoftwarerequirements), introspection will fail and cause that error.

View solution in original post

Communicator

I had this error on 1/10 index`ers - restarted splunk twice and it solved the problem

0 Karma

Splunk Employee
Splunk Employee

If this is not a Windows system or the prerequisites haven't been met (http://docs.splunk.com/Documentation/AddOns/latest/MSPowerShell/Hardwareandsoftwarerequirements), introspection will fail and cause that error.

View solution in original post

Path Finder

When I click on your link it takes me to http://docs.splunk.com/Documentation

Its Windows 2008 R2.

0 Karma

Splunk Employee
Splunk Employee

huh... just double-checked the link and it's correct, and works in everything but answers. I'll investigate with the appropriate people. To navigate to the requirements from the Documentation root, scroll down to Splunk Supported Add-ons, click Splunk Add-on for Microsoft PowerShell, expand Installation and Configuration, and click "Hardware and Software Requirements for the Splunk Add-on for Microsoft PowerShell". Alternatively, google for "Hardware and Software Requirements for the Splunk Add-on for Microsoft PowerShell" and it will be the first link after the ad.

0 Karma

Splunk Employee
Splunk Employee
0 Karma

Path Finder

Jcoates taking a closer look at your link it includes the right bracket and comma which caused the link not to work. I have noted this on other folks (other posts) links as well that when I click on it it takes you to the generic documentation page, could be a bug when inserting links.

On the question at hand I did manage to view the requirements and simple installed .NET 3.5. So even though the app appeared to be working fine it needs the older .NET to avoid the error?

0 Karma

Splunk Employee
Splunk Employee

I bet it was trying to introspect and validate powershell2 stanzas?

0 Karma