All Apps and Add-ons

Not getting pipeline data

DvDongen
New Member

Hello,

I'm trying to get pipeline stage data from Jenkins to Splunk.


The extended Splunk plug-in was already installed on Jenkins. As far as I understand it I merely have to  hit the checkbox for "Send All Pipeline Console Logs" in the configuration of Jenkins.
I've tried this, but it doesn't seem to work: When I go to a build event of a pipeline in the Jenkins app in Splunk and click on the "Job Stage Pipeline"-tab I get the message "No pipeline data". When I look across the indexes in Splunk I'm not able find any pipeline-data either (though I can find the generic job event).

The fact that the 'normal' data seems to come through to Splunk but the pipeline data is missing is confusing me. I've tried some other approaches, but to no avail.

Does anyone know what's going on? What index is the data supposed to go into anyway? (Does the configuration change require a restart from Jenkins?)

Labels (2)
Tags (1)
0 Karma
Get Updates on the Splunk Community!

Detecting Remote Code Executions With the Splunk Threat Research Team

WATCH NOWRemote code execution (RCE) vulnerabilities pose a significant risk to organizations. If exploited, ...

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...